New and Modified Features: [WebAccess Remote and Amazon S3] - The maximum number of files that can be copied to the remote folder at once is expanded from 10,000 to 100,000. - Additional network errors with Amazon S3 are now displayed. [Backup] - You can now specify how many normal backups to keep. - The folder for backup logs is now configurable. - When creating backup jobs, the LAN port numbers (LAN1 or LAN2) of source and target TeraStations are now shown. - Error codes are now displayed when backup jobs fail. [Replication] - When configuring replication, the LAN port numbers (LAN1 or LAN2) of source and target TeraStations are now shown. [Update] - Added scheduled firmware updates. - Added automatic firmware update (when new firmware is detected). [System] - CPU and memory utilization is now displayed. [Drives] - S.M.A.R.T is now supported for the TeraStation's internal drives. [Network] - IP address, subnet mask, default gateway, and DNS servers can now be configured from the same settings page. Bug Fixes: [UPS] - Fixed a bug where blackout was falsely detected when the self test was run on Schneider Electric (APC) UPSs. [Network] - Fixed a bug where backup failed with the Ethernet frame size configured to 9216 bytes on 5000 series TeraStations. Now, Ethernet frame sizes of 1500, 4084, 7404, and 9216 bytes are supported. [Users] - Fixed a bug where a user's primary group was not changed when the user joined a new group. [Update] - Fixed a bug where the wrong error was displayed when the network was disconnected during a firmware update. - Fixed a bug where the guest account was enabled after the firmware was updated from version 2.50. [Amazon S3] - Fixed a bug where folders on the TeraStation could not copied to the Amazon S3 remote folder after recovering from network disconnection. [RAID] - Fixed a bug where I17 kept displaying after resync and rebuild were completed when the TeraStation was in degraded mode because drives had been dismounted during resync. [Email Notification] - Fixed a bug where the wrong body text was included in the notification email for changing the RAID mode from RAID 1 to RAID 5 with RMM enabled. - Fixed a bug where the date in the sent email header was blank. - Fixed a bug where the source backup folder's name was not logged when the backup completed if the folder name contained a single-byte space. [Replication] - Fixed a bug where replication failed if any file handling were operated to the replication source target more than 8 hours. - Fixed a bug where replication failed if a shared folder which contains a single-byte space in its folder name was configured as a replication source folder. - Fixed a bug where replication could not be configured if the replication target folder had a multi-byte space in its name. - Fixed a bug where a replication error message was still displayed after the replication task was deleted. [Drives] - Fixed a bug where a formatted media cartridge showed "Unformatted" if it was inserted while the TeraStation was off. [File Sharing] - Fixed a bug where access restrictions were disabled for a folder when all users with access privileges to the folder were deleted. - Fixed a bug where the dialogue that a shared folder was created was not displayed with IE 8. - Fixed a bug where extra folders were created when recovering settings from a USB device if the shared folder's description contained a single-byte space. [Direct Copy] - Fixed a bug where Direct Copy could be enabled for a folder with a blank folder name.