Intel ir3 2208 ROC Hardware RAID Firmware 23.18.0-0013

Versions: - MR Firmware – 3.290.05-2720 - Ctrl-R – 4.02-0001 - BootBlock – 2.05.00.00-0010 - BootBlockCommon – 07.26.13.219 - ROMENV – 1.08 Fixes: - Virtual Drive creation failure in iMR during pre-boot - Recon VD made "degraded" when the recon pd is pulled out allowing for rebuild once the drive is plugged back in. - Static variable used in PD Progress and LD Progress function which may affect multiple progresses running at the same time. - MegaRAID controller does not display a boot message when it has entered safe mode. - Allow adding a lba when table entries are exhausted, but addition is possible if consecutive to existing entry - When pulling and pushing SSD SATA PDs under 5 seconds, the SSDs come back as failed after a minute or so. - Hard coded values should be removed in TFM module - Potential IO integrity with R0/R1 CIO WT when overlapping R/W issued to LD. - Unable to perform Consistency Check and other background operations in a legacy WebBIOS - Multiple VDs undergoing full init show a calculated estimated time remaining even though they sit at 0% - FW reports "Progress init not proper" during 16 VD Rebuild - Data miscompare seen when errors injected to a RAID6 virtual drive - Potential data integrity issue During Check Consistency On 4DG R6 arrays with 16 VDs per array - Delete VD while PR still in progress cause debugger to loop. Reboot the system, debugger still loops - Sequential Read performance is less on CacheCade associated LD's. - If a BOOT Passphrase is enabled with SafeStor "MegaCli adpbios dsply a0" will display "BIOS will Stop on error" even if any other mode is set. - Message release issue in immediate IO path - Firmware crash during foreign config import - Verify drive reinsertion within/before drive-removal-delay setting -verify discovery (Without IO) - HII - Profile based VD creation - [Partial RAID options blocked until system reboot] - Application could not make a JBOD bootable without a VD present - Potential data integrity issue with a 4K RAID5 virtual drive - HII /When user has a critical message and the conrtoller is in Safe Mode, going into CTRL mang will result an error msg - Staggered CMEs across R10 array are causing a read error - Learn cycle will not start on supercap - UEFI-4K drives: Unable to create any virtual drives of strip size 256k-1MB with the 4K sector drives. - Event is blocked during Full initialization - iMR firmware does not progress background operations with certain systems when using WebBIOS in legacy mode - Fw defects related to Disk Write Cache Policy settings - Grammatical spacing error in bios message at POST - The elapsed time shown in the FW debugger for a reconstruction not starting at 0 - 23.16.0.0005/Creating CacheCade with non supported OEM SSD using older FW and then flashing to 5.7 it's till available - "Question value mismatch with Option Value" message in HII's Controller Management when in Safe Mode with pin cache - Rebuild failed event is not seen when rebuild fails due to LDBBM and SBBM tables getting full (puncturing disabled) - Remove memory module on MR controller to downgrade to iMR does not work - Firmware failed to import drives to start rebuild after remove then reinsert - LDBBM_EXT table does not get read during init - Significant drop in Sequenial read performance with Read Ahead policy - Multi-stripe size in each raid level of R1,r5,r6 with SAS, DIF, 4K pinned cache offline vd import cause Montask - Setting the ASO key with storcli 1.02.08 (MegaCli 8.07.06) fails with an error code 3 on Windows or Linux if the MB BIOS PCI - Data Miscompare found while running I/O overnight with degraded virtual drives - HII critical message form/Extra character "r" with configuration not supported critical message. - Prevent overtemp warnings while battery is charging - CLI Reporting of TMM VPD - EKMS disabled in firmware by modifying support EKM property in a proper way. - Modify MR fw to eliminate four second window where drive swap is not recognized. - Rebuild automatically starts on drive with foreign configuration after reboot. - Modify sense data returned for an offline VD - Availability of information on PFK hardware keys presence/absence via termlog. - HA/Peer controller detection and handling logic - R5 rebuild fails source drive after LDBBM table is full - Defect fix for crash when fde disk connected - Ctrl+R BIOS hangs while hot plug of 2 enclosures with more than 32 drives on FURY controller - Sequential Read performance is less on CacheCade associated LD's. - The reliability and error recovery of the SuperCap firmware was improved. - Adjusted the USB phy boost value for the OEM controllers - IO integrity error seen after Source VD associated with CacheCade VD is forcibly unblocked - During rebuild on PRL11 CacheCade VD and rebuild on RAID6 Source VD IO integrity error is seen. - BBU Charging gets disabled when Transparent Relearn fails to start due to low capacity - On iMR FW update caused card to FW fault state and card cannot boot to OS. - SEAGATE hotspare drives remain spun up on LSI FW 12.12.0-0079 - After COR (OCR) controller not longer available to HOST - Change SES Green/Amber LED behavior for OEM JBOD enclosure. - Customer is hitting an ECC bug - Firmware returns invalid data in OOB packet - OEM facing with incorrect SAS HDD's indication, MSM shows 2X drives connected - Alarm continues to sound after copy-back is done, across reboot, from an unconfigured good drive that is used as an emergency spare. - Change RAID controller FW bad battery warning message that comes up during POST. - 2208 ROMB see 0 Capacitance - Deep learn doesn't start when it is requested during relaxing. - Auto Foreign import fails when controller is booted with pinned cache. - Power loop cycle test on a non DIF drive connected to LSI controller caused fatal firmware error - When a Cachecade PD marked as missing is reused to make Cachecade VD IO integrity error is observed. - If a correctable ECC error occurred during a cache offload, the CPU would crash, resulting in a data loss - Copy back on a drive hits kill adapter - Immediate IO broken for R1 - disableHII: Needs to be updated from nvdata into MFCD - Infinite retry happens on Test Unit command when HDD didn't respond to TU command during the initialization. - Enable DS3 on TB code for OEM - TFM error handling : Cache policy change for WB to WT if supercap is faulty - OEM- StorCli should not allow turning on JBOD in MR mode - Deep Learn is not invoked in new battery, when the system is reboot before the first learn completes - Transparent Learn Cycle is rescheduled even though it is not completed - Write policy changed from WT to WB when the battery/Supercap is declared as bad - OCR observed after IO on reconstructed VD with ME's - Wrong event generated "Reminder: Potential non-optimal configuration due to drive PD xx(e0xfc/sx) commissioned.. - If the hotspare was spun down, the copy back after a drive failure wouldn't always start. - adapterOperations.alarmControl is being set to 1 even if controller does not have alarm on board - Unable to open "Set Patrol Read Properties" in MSM with 2008-iMR - If VD is secured while reconstruction is going on does not stay secured once reconstruction is done. - Allocate BBLog for iMR Initially during boot up - When attempting to secure LD during RLM, receive option to secure LD, LD not secured (message incorrect/misleading.) - Saved Release Note DataSLIB returning bad data as good data after host reboots - Minimum Capacity needed for relearn is incorrect in 2208 MR FW - Improve foreign config import for iMR with mixed JBOD/RAID settings - Correct the error in copy back path smart errors path - Defect fix for VD rebuild does not kick in and goes to foreign state after reboot - Disconnect SCap during Shutdown/Hibernate only if pinned cache is not present - spare pointer is incorrectly used in MR_CONFIG_DATA - Fix For code analysis Defects Reported - Change RAID controller FW bad battery warning message that comes up during POST. - Patrol Read - no progress - ECC/Medium/Unrecoverable read errors handling Enhancement - FW halts when you have pinned cache and remove VD form the configuration. - If the hotspare was spun down, the copy back after a drive failure wouldn't always start. - Invalid target ID after new logical drive creation - sync error stat for MRS - CMDTool2 reports battery pack is missing on hot insertion - Card Running iMR Machine Checks when Requesting Host Memory - Infinite retry happens on Test Unit command when HDD didn't respond to TU command during the initialization. - Virtual drive configurations go missing during firmware upgrade from 5.3 to 5.7, while running Consistency Check (CC), after two reboots - Fix for the defect - 4k drives display wrong value of Coerced size. - Write policy changed from Write-through (WT) to Write-back (WB) when the battery/Supercap is declared as bad - Profile based VD creation path incorrectly showing protect VD/secure VD check box when user clicks on drive selection criteria - HII cannot assign partial space less than 1 GB - HII 03.03.04.00/Profile based configuration help issues - HII 03.03.03.00/PKG 5/When creating an invalid argument in HII during VD creation and after correction, save is grayed out - Hii failed to report error warning when config 2pds R10 with different drive capacity - UCM - Virtual Drive Configuration summary does not report the "Interface Type" - HII: Navigation issue from Enable Drive Security form - HII does not allow user to use the remain free capacity to configure additional VD for R50/R10. - HII failed to allow user to use the remains free capacity for R1 VD with 2 plus TB capacity. - Hii enter black screen/timeout when user switching between fields/form sub_form to create R10 VD on PERC9 controller. - Hii failed to report warning that inappropriate drives are picked to config R10 VD. - New Field "package version" in Controller Management - UCM Driver - unable to create an 8PD R5 - BBU information and properties are not displayed in HII browser for Perc9-H730P controller. - HII Manage Foreign Configuration menu is not available when a foreign locked drive is present in the configuration - UEFI System hang if controller FW is in fault state - Not possible to probe a volume > 2Tb on Niwot raid card - In WebBIOS, if BGI is suspended the vd progress info page shows it as CC progress until it is resumed - Incompatible strip size convention in TB - Change in product name for OEM 2208 ROMB design This download is valid for the products listed below: - Intel Integrated RAID Module RMS25CB040 - Intel Integrated RAID Module RMS25CB080 - Intel Integrated RAID Module RMS25PB040 - Intel Integrated RAID Module RMS25PB080 - Intel Integrated RAID Module RMT3CB080 - Intel Integrated RAID Module RMT3PB080 - Intel RAID Controller RS25AB080 - Intel RAID Controller RS25DB080 - Intel RAID Controller RS25NB008 - Intel RAID Controller RS25SB008 -

  • Разработчик: Iriver
  • ОС: OS Independent
  • Размер: 14.5 MB
Скачать